Monday, August 15, 2022
HomeiOS Developmentswift - "... is simply obtainable in iOS 13.0 or newer" in...

swift – “… is simply obtainable in iOS 13.0 or newer” in a venture focusing on iOS 15.0

[ad_1]

I am utilizing Xcode 13.4 and have created a brand new SwiftUI venture utilizing the “iOS app with watch app” venture template. The goal for the primary app is ready to iOS 15.5 and the watch goal is ready to WatchOS 8. Every little thing was constructing and operating on the simulator effective.

I’ve simply added the watch-date-picker Swift package deal to my venture, and now I am unable to construct my venture – I get tons of errors within the added watch-date-picker package deal’s code complaining that numerous issues are solely obtainable in iOS 13.0 or newer. I have not even tried utilizing the library but – I’ve simply added it by way of File -> Add Packages

I am confused why I am getting this error – so far as I can inform, I am focusing on later (15.5). Can anybody clarify why that is and what I can do to resolve it? Am I lacking one thing? I’ve tried cleansing, deleting derived information, closing Xcode, nothing works. Thanks!

enter image description here

enter image description here

enter image description here

[ad_2]

RELATED ARTICLES

Most Popular

Recent Comments